jQuery 1.9和2.0版路线图问答集锦

英文原文:blog.jquery,编译:高博

导读:jQuery 官方博客 6月 28 日发了一篇博文,文中透露了 jQuery 的部分路线图,其中透露 2.0 版将不再支持IE 6/7/8。不少开发人员评论说2.0 版可以支持IE 7/8,jQuery 官方博客于7月1日再发一文,针对各种评论,做了解答。

0. 为什么jQuery核心团队不再支持旧版本的IE了(IE6/7/8)

我们没有不支持!明年发布的jQuery 1.9将继续支持旧版本的IE。即使在jQuery 2.0发布以后,jQuery团队也会继续支持和维护1.9版本的。

1. 你们为什么强迫我在包含jQuer库的时候使用条件式注释呢?

我们没有强迫人们这么做!你完全可以仅使用jQuery 1.9,它可以用在我们支持的一切浏览器上,包括从IE6一直到最新版本的Chrome、Safari、Opera和Internet Explorer。

jQuery

2. 等jQuery 2.1版发布,并增加了一些API的话,会怎么样呢?jQuery 1.9还能与时俱进吗?

我们可以借你的水晶球看看未来吗?jQuery2.1不太可能在2014年以前发布,所以在2012年年中就谈论jQuery2.1长成什么样子挺难的。我们的总体方针是保持1.x和2.x的产品线同步更新,并通过插件来增加功能,具体情况可参见上周的主题演讲。

3. 你们会支持jQuery 1.9多久?

只要旧版本的IE还在web上占有一定的比例,我们就会继续支持下去。甚至1.x产品线还可能会推出后续版本,但是我们还没收到在上个问题中向你要的水晶球呢!微软将在2014年4月中止对Windows XP的支持,无论如何,那将是对旧版本的IE安装平台的一个严重打击。

4. 我的IE8用户还不少,你就不能仅仅放弃IE6和IE7吗?

旧版本的IE有很多缺陷都是一样的,如果不在jQuery 2.0里把三个版本一次全干掉的话,基本上能做的改进就有限了。如果你需要任一旧版本的IE,有着官方支持的jQuery 1.9随时恭候您的取用。

5. 我的网站在中国,那里有22%的用户仍在使用IE6!

Seems like some sort of human rights violation. Oh, and that wasn’t a question. 听上去像是和侵|犯|人|权有关的问题。哦,这种问题从来就不算一回事儿。

 

 

 

 

收藏 评论

相关文章

可能感兴趣的话题



直接登录
跳到底部
返回顶部